Ravindar, Biztalk Developer and Administrator

Just another BizTalk blog

Enterprise SSO service start failure after installing VS2010

BizTalk and SSO was running smooth before the installation of VS2010 on my machine. I have a 64-Bit machine with Windows Server 2008 R2 and BTS 2009 installed. When I installed VS2010 my SSO was stopped and when I tried to start I started getting the error below

—————————
Services
—————————
Windows could not start the Enterprise Single Sign-On Service service on Local Computer.

Error 0×80131700: 0×80131700

To issue started because it unregisterd SSOSQL.dll which is found on C:\Program Files\Common Files\Enterprise Single Sign-On folder. To register it again run regasm on the VS command prompt from your 32-Bit machine.

regasm C:\Program Files\Common Files\Enterprise Single Sign-On\SSOSQL.dll

On my 64-Bit it worked by running the 64-Bit regasm which is found on C:\Windows\Microsoft.NET\Framework64\v2.0.50727.

So go to the framework64 folder from the command prompt and run

regasm C:\Program Files\Common Files\Enterprise Single Sign-On\SSOSQL.dll

Advertisements

June 10, 2011 - Posted by | Asp.Net, Biztalk Server

No comments yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: